Follow

Split Recording into Separate Tracks

Splitting recordings into separate tracks

From Audacity Wiki

 
If you have a vinyl or cassette recording with separate tracks on it, you most likely want to export those tracks as separate audio files for your computer's music library, or so you can burn them to separate tracks on an audio CD. This is easily accomplished in Audacity, using labels and the export multiple function.


Related pages:

Transferring tapes and records to computer or CD

How to burn CDs

Contents

// <![CDATA[ if (window.showTocToggle) { var tocShowText = "show"; var tocHideText = "hide"; showTocToggle(); } // ]]>

Preparations

Using labels to split your recording into multiple tracks requires you to record all your tracks into one audio track on the Audacity screen. To achieve this when you are recording, click Audacity's blue Pause button (not the yellow Stop button) whenever you want to turn over the record or tape, then click Pause again to restart the recording in the same track. Use "Stop" only when you have completely finished recording into that audio track.

 
Pause
Pause
Stop
Stop
Over-long pauses or noise/rumble can be deleted later at the editing stage by selecting the audio in question and using the Edit > Delete command.


The labelling feature described below should not be used if you already have more than one audio track in the Audacity screen (for example, one audio track for each side of an LP). If you have recorded your LP or cassette tracks into more than one Audacity track, you can join them into one track thus:

  1. Select the second track by clicking in its Track Panel (where the mute/solo buttons are).
  2. Choose Cut from the Edit menu.
  3. Place the cursor in the white space after the end of the audio in the first track.
  4. Choose Paste from the Edit menu.
  5. Close the second track by clicking the [X] top left of its Track Panel.

Simply repeat the process for any additional tracks you have open.

If you are using a 1.3.x Beta version of Audacity, instead of step 3, click anywhere in the first track then press END on your keyboard, then steps 4 and 5.

Labels

Labels not only mark a split point, but also allow you to name the individual snippets so they correspond to each LP or cassette track. These names can be used as file names when you finally export the files. The labels appear in a new Label Track underneath the audio track as you can see in the example below. This happened to be a mono recording but the labels are exactly the same if you have a stereo recording.

Image:Labelsresize.png

To add labels to mark the split points between the LP or cassette tracks, do this:

  1. click in the recorded audio track at the start of each LP or cassette track, starting at the point where the first track starts.
  2. click Project > Add Label at Selection (in 1.37: Tracks > Add Label at Selection) (or its hotkey, CTRL + B)
  3. optionally, start typing the name of the song immediately after Add Label at Selection (notice that what you are typing should now appear in the label to the right of the flag, in the Label Track). You can skip typing in the labels if you prefer, and instead choose a numeric sequence when you come to the Export Multiple command.
  4. if you wanted to lengthen the gap between this track and the previous one, you could do it now: click in the audio track in the current gap, then Generate >Silence and choose the length of silence to insert. You could also silence a noisy gap by selecting the area of the gap and then Generate > Silence (or use the Edit > Silence hotkey CTRL + L). Note however that noise between tracks can be used as a noise profile for removing noise from the recording.
  5. click at the start of the second track (this confirms any typing you made in the label),Project > Add label at Selection again, type the second label and so on.

 

If you cannot type in the label at any stage, click in it to give it focus, then type.


If you make a typing error, press Backspace. If you get the label in the wrong place and want to delete it, click on it and press Backspace until you have deleted all of the characters in the label, then press Enter. In 1.3 Beta, pressing Backspace after the last character is deleted automatically deletes the label. To delete multiple labels, select an area in the Label Track containing all the label flags you wish to delete, and choose Silence or Delete from the Edit Menu. If you want to remove the Label Track and start over again, click the [X] far left of the Label Track to close it.

Note that if you cut or delete a section of the recording after you have placed labels, this will leave the labels in the wrong place. To solve this, select the area to cut or delete in both the audio track and the Label Track.

Each name you type in the label must be different. Two notes here: First, avoid using system-prohibited characters in the labels. These will cause a "cannot export audio to..." or "unable to open target file for writing" error, or in the case of colon ":" will cause the exported file to be invalid. Here are examples of common system-prohibited characters:

  \ /  : *  ? " < > |  


All the above characters will fail on Windows. "/", "\" and ":" will fail on Macs. These are operating system limitations. If you want to use quotations in your labels, use two ' characters together. Second, if you're using a 1.2.x version of Audacity, you cannot type a lower case "z" in the label due to a bug. You can type an upper case "Z". This is already fixed in the Beta 1.3.x development version of Audacity, but in 1.2.x, go to the Keyboard tab of Preferences and change the hotkey for "Find Zero Crossings" from Z to CTRL + Z, or to some other combination that includes a modifier such as CTRL or ALT. Alternatively, simply copy the letter `z` from here and paste it into the label name.

Automatic labelling based on silences

If you have well defined silences preceding the starts of each track, go to the Analyze menu > Silence Finder. Silence Finder will attempt to automatically label the track split points based on the silences between the tracks.

If Silence Finder is not in Audacity you can obtain it as a Nyquist plugin here . Simply select and copy the full text that appears when you click the link, and paste it into a new empty text file in Notepad or similar text editor. Ensure WordWrap is off. Then save it as silencemarker.ny. Alternatively, go here , scroll down to SilenceMarker.ny, right-click or control-click over the link and save it to your drive. Then move SilenceMarker.ny into the Plug-Ins folder inside your Audacity installation folder and restart Audacity. On Windows machines, Audacity's installation folder by default is at:

C:\Program_Files\Audacity

On Mac OS X, it is usually under Applications.

If there is a long silence after the end of the last track, Silence Finder may well add a superfluous label here. To delete this label and the silence, select the area of audio you want to cut and drag the selection down into the Label Track, then Edit > Silence or Edit > Delete.

 

Export Multiple

The File > Export Multiple command will export all your audio files at one go (one per LP track, each with its own filename), based on your chosen split points. When you click File > Export Multiple, a dialogue box pops up where you choose your Export Format, the Export Location, and how to name your files.

Image:exmult.jpg

Above you can see the default settings of the dialogue once you have chosen the Export Format and Export Location.


Export Format

Choose WAV or AIFF if you are going to burn an audio CD. Choose MP3 if you want a smaller file for storage on your computer or on a portable player like an iPod. Note MP3s have slight quality loss compared to WAV or AIFF which have perfect quality. If you want to export to MP3, you need to add the LAME MP3 encoder to your computer and tell Audacity where it is - see Lame Installation for help on this. Note that whenever you're exporting as MP3, its Title ID3 tag will be automatically determined by the exported filename, and the Track Number ID3 tag will be automatically determined by the order of the tracks on screen.


Export Location

In 1.2.x versions of Audacity you need to choose a directory that already exists - you cannot create a directory by typing its name in the Export Location box. Beta 1.3.3 or later does allow you to create a new directory in this way, or to make a new folder in the dialogue that pops up when when you click "Choose".

To export your files to iTunes (for example to transfer to an iPod), choose any suitable location on your hard drive, and import the files into iTunes from there. Audacity cannot export to Apple formats like MOV or MP4, but if you want to have your recording in MP4 format, you can export it as either WAV or AIFF as above and convert it to MP4 in iTunes. See further help exporting to iTunes or iPod.


Split files based on...

When you are splitting a long single track up by using Labels as in this tutorial, the Labels button is automatically selected and cannot be deselected. As an option, you can check the box "include audio before first label". This will enable you to place your first label at the start of the second song instead of at the start of the first song, which is one less label to place. Type the name you want for this first file name in the "First file name" box.


Name Files

If you've typed the exact name you want for each track in the label, you'll want to leave the "Name Files using Label/Track Name" button selected, then each exported audio file will have exactly the name that you typed.

If you did not type in the labels, and you leave the "Name Files using Label/Track Name" button selected, your exported files will be named in the form ".wav", "-2.wav" and so on. If you want to give your files a more elegant name, select the "numbering consecutively" button instead, and type a name in the "File name Prefix" box underneath the button. This word or phrase will then be the prefix for a numerical sequence. For example, if you type in the box "Serenade", the exported files will be in the form "Serenade-1.wav", Serenade-2.wav" and so on.


Overwrite existing files

Generally, leave this box checked. If checked, Audacity will simply overwrite any existing files with the same name without asking. This is useful if for example you don't like the files you exported, or got the labels in the wrong place, and want to export multiple again. If you uncheck this box, Audacity will process the multiple export, but if it encounters previously exported files with the same, it will create new files with "-2" or similar appended to the filename.

Extra notes about burning to CDs

Before you Export Multiple for real there are three things you must do:

1) Most users want to burn an "audio CD" that will play on standalone CD players (not just in their computer). To do this you must configure Audacity to export 44 100 Hz, 16 bit stereo WAV or AIFF files, so that the files are compatible for burning as an audio CD. To do this:

  • At the bottom of the Audacity window set the Project Rate to 44 100 Hz.
  • On the File Formats tab of Preferences, in the "Uncompressed Export Format" dropdown, choose WAV (16-bit...) or AIFF (16-bit...).
  • If your Project does not already contain a stereo track, click Project > New Stereo Track (or Tracks > Add New > Stereo Track in Audacity 1.3.3 or later). It does not matter that this track is empty, its purpose is just to make Audacity export your recording as a stereo file.

Make sure you specifically tell your burning software to burn an "audio" or "music" CD, not a "data CD". For more help on burning CDs, see How to burn CDs.

2) Make sure your Project Rate (Hz), as shown in the Project Rate button bottom left of the Audacity screen, matches the rate showing in the Track Panel (where the mute/solo buttons are). If you don't do this, and you're exporting WAV or AIFF files, silences may be added at the end of tracks and the labels may not export in the correct position. This is due to a bug when resampling is done between the Project and Track Rate upon export. If necessary you can select your track by clicking in the Track Panel then Project > Quick Mix, which will resample the track to the Project Rate. Then simply delete the excess silence generated at the end of the track and the export will have no added silence. In 1.3.x, click Tracks > Resample, and in the box that pops up, enter the rate showing in the Project Rate button.

3) Set Audacity to make your track splits at the 1/75th second frames that CDs use. This should ensure that you will not get clicks between tracks on account of the burning process, and that CD burning programs should be able to burn without pauses if you don't want to add gaps between the tracks in the burning software. To enable splits at CD frames in Audacity 1.2.6:

  • Click View > Set Selection format, and select "CDDA min:secs:frames 75 fps"
  • Then click Edit > "Snap to" and choose "On".

In 1.3.x instead of step 1) above, you click on one of the downward pointing arrows in any of the three fields in the Selection Bar (see http://audacity.sourceforge.net/download/features-1.3-d.php ) in order to choose the selection format.

 

Gapless burning

By default, many CD burning programs will add a 2 second gap between CD tracks, so be aware of this when placing your labels, and consider deleting excess silences between tracks. While most programs will optionally let you burn the CD with no gaps between the tracks, some including Windows Media Player, have no such option. If you have Windows Media Player 9 and Nero burning software, you can try this plugin  which should allow you to burn directly from Media Player with no gaps.

Unfortunately, the "no gap" option in some burning software still leaves a momentary but perceptible gap between tracks, which is an irritation if your audio track is a continuous piece of music. While you can solve this problem by exporting your track as a single audio file, so you only have one CD track, you then have no means of navigating around the CD. There are two solutions. The first is to use CD burning software and a burner that supports "disc at once" (DAO), in which the tracks are burned without turning off the laser. Sometimes, "no gap" is equivalent to "DAO", but sometimes it isn't. So check the manual for your burner and software - the vital thing is that the laser runs across the tracks without interruption.

Additionally, make sure you don't export MP3 files for burning to your gapless CD, even if you're burning a "data CD", because MP3s have inherent silence padding due to a restriction of the MP3 format.

An alternative and recommended solution is to not split the track up at all in Audacity. Instead, export it as one long file, and burn that file with DAO and a "cue sheet" that marks the starting times of each CD track. Cue sheets can be created as simple plain text files. Audacity currently has no direct means of creating a cue sheet from the track labels, however if you use Audacity's File > Export Labels command, you can export track starting times and label name data as a text file. This file could then be edited to make a cue sheet.

Each track in a Cue Sheet is of this format:

  • TRACK (number) AUDIO
  • TITLE "(name)"
  • PERFORMER "(name)"
  • INDEX 01 (start time) in the format minutes:seconds:frames with the first track always being 00:00:00


Audacity cannot currently export Cue Sheets but it is possible to use the File > Export Labels command to export a text file representing the label positions, then on Windows and Linux use label2cue to convert the minutes and seconds data in the text file to minutes, seconds and frames data laid out in cue sheet format.

Note you may still hear hear the most momentary gaps between tracks even on DAO burned CDs, unless the CD player supports true gapless playback. Many CD players do not support gapless playback properly because the hardware simply doesn't buffer the audio data properly. However quite a few computer-based media players can use DSP effects when playing back audio to give proper gapless playback, even of CDs not burned with DAO. An example of such a player is Apple's iTunes 7 .

Comments

Powered by Zendesk